Ethereum issue
Incident Report for Shoppy
Resolved
This incident has been resolved.
Posted Dec 28, 2018 - 13:07 CET
Identified
We are currently experiencing an issue with the connectivity to the Ethereum network. Orders may confirm slower.
Posted Dec 28, 2018 - 12:49 CET
This incident affected: Payments (Ethereum).