Email backlog
Incident Report for Shoppy
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 02:36 CEST
Investigating
We are currently investigating an issue with our emails not arriving in time.
Posted May 31, 2020 - 23:24 CEST