Ethereum issues
Incident Report for Shoppy
Resolved
This incident has been resolved. We are monitoring closely.
Posted Sep 08, 2019 - 22:43 CEST
Investigating
We are currently experiencing issues processing Ethereum payments.
Posted Sep 08, 2019 - 17:17 CEST
This incident affected: Payments (Ethereum).